| DnsARecordData | Represents a DNS A record containing an IPv4 address (RFC 1035). |
| DnsAaaaRecordData | Represents a DNS AAAA record containing an IPv6 address (RFC 3596). |
| DnsCaaRecordData | Represents a DNS CAA (certification authority authorization) record (RFC 8659). |
| DnsCnameRecordData | Represents a DNS CNAME record (RFC 1035). |
| DnsDnameRecordData | Represents a DNS DNAME (delegation name) record (RFC 6672). |
| DnsDnskeyRecordData | Represents a DNS DNSKEY record for DNSSEC (RFC 4034). |
| DnsDsRecordData | Represents a DNS DS (delegation signer) record for DNSSEC (RFC 4034). |
| DnsEdnsOption | Represents an EDNS option within an OPT record. |
| DnsHinfoRecordData | Represents a DNS HINFO (host information) record (RFC 1035). |
| DnsLocRecordData | Represents a DNS LOC (location) record (RFC 1876). |
| DnsMxRecordData | Represents a DNS MX (mail exchange) record (RFC 1035). |
| DnsNaptrRecordData | Represents a DNS NAPTR (naming authority pointer) record (RFC 3403). |
| DnsNsRecordData | Represents a DNS NS (name server) record (RFC 1035). |
| DnsNsec3ParamRecordData | Represents a DNS NSEC3PARAM record for DNSSEC (RFC 5155). |
| DnsNsec3RecordData | Represents a DNS NSEC3 (hashed next secure) record for DNSSEC (RFC 5155). |
| DnsNsecRecordData | Represents a DNS NSEC (next secure) record for DNSSEC (RFC 4034). |
| DnsOptRecordData | Represents a DNS OPT pseudo-record for EDNS (RFC 6891). |
| DnsPtrRecordData | Represents a DNS PTR (pointer) record (RFC 1035). |
| DnsRpRecordData | Represents a DNS RP (responsible person) record (RFC 1183). |
| DnsRrsigRecordData | Represents a DNS RRSIG (DNSSEC signature) record (RFC 4034). |
| DnsSoaRecordData | Represents a DNS SOA (start of authority) record (RFC 1035). |
| DnsSrvRecordData | Represents a DNS SRV (service) record (RFC 2782). |
| DnsSshfpRecordData | Represents a DNS SSHFP (SSH fingerprint) record (RFC 4255). |
| DnsSvcParam | Represents a service parameter in SVCB/HTTPS records. |
| DnsSvcbRecordData | Represents a DNS SVCB or HTTPS (service binding) record (RFC 9460). |
| DnsTlsaRecordData | Represents a DNS TLSA (certificate association) record for DANE (RFC 6698). |
| DnsTxtRecordData | Represents a DNS TXT record (RFC 1035). |
| DnsUnknownRecordData | Represents an unknown or unsupported DNS record type. |
| DnsUriRecordData | Represents a DNS URI record (RFC 7553). |