DnsResponseCode Enum
Specifies DNS response codes as defined in various RFCs.
public enum DnsResponseCode : ushortFields
| Name | Value | Description |
|---|---|---|
NoError | 0 | No error condition (RFC 1035). |
FormError | 1 | Format error: the name server was unable to interpret the query (RFC 1035). |
ServerFailure | 2 | Server failure: the name server was unable to process the query (RFC 1035). |
NameError | 3 | Name error: the domain name referenced in the query does not exist (RFC 1035). |
NotImplemented | 4 | Not implemented: the name server does not support the requested operation (RFC 1035). |
Refused | 5 | Refused: the name server refuses to perform the operation (RFC 1035). |
YxDomain | 6 | Name exists when it should not (RFC 2136). |
YxRRSet | 7 | RR set exists when it should not (RFC 2136). |
NxRRSet | 8 | RR set that should exist does not (RFC 2136). |
NotAuthoritative | 9 | Server not authoritative for zone / not authorized (RFC 2136). |
NotZone | 10 | Name not contained in zone (RFC 2136). |
BadVersion | 16 | Bad OPT version (RFC 6891). |
BadKey | 17 | Key not recognized (RFC 2845). |
BadTime | 18 | Signature out of time window (RFC 2845). |
BadMode | 19 | Bad TKEY mode (RFC 2930). |
BadName | 20 | Duplicate key name (RFC 2930). |
BadAlgorithm | 21 | Algorithm not supported (RFC 2930). |
BadTruncation | 22 | Bad truncation (RFC 4635). |
BadCookie | 23 | Bad/missing server cookie (RFC 7873). |